Item Denomination Change - Boscov's eGift Card
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Nov 08, 2021 - 09:43 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 20, 2021 - 09:05 PDT
Investigating
Effective today, the range of Boscov's eGift Card is $15 - $250 USD.
Please ensure all future Boscov's eGift Card orders comply with the updated variable range of $15 - $250 USD.

The affected UTID is: U747187
Posted Jul 20, 2021 - 09:05 PDT
This incident affected: Americas (USD).