Item Outage - Wolt Karta Podarunkowa Polska zl50

Incident Report for rewards

Resolved

This item is still currently out of stock, however we have closed this ticket as the entire brand is out of stock and there is a new ticket open. Please see the most current status page for availability updates here: https://rewardstatus.tangocard.com/incidents/11jftw48wtwj
Posted Sep 08, 2025 - 10:04 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U204028
Posted Sep 08, 2025 - 06:24 PDT
This incident affected: Europe (PLN).