Brand Outage - La Rinascente Italy

Incident Report for rewards

Resolved

This brand is no longer available and the incident has been closed. Here's the link to the most recent status update:
https://rewardstatus.tangocard.com/incidents/gy6spkzbk6fp
Posted Oct 03, 2025 - 07:35 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U666431, U260458, U586705
Posted Jul 08, 2025 - 15:55 PDT
This incident affected: Europe (EUR (Italy)).