Catalog Change Notice - JB Hi-Fi Gift Card Australia

Incident Report for rewards

Resolved

This change is now live. The updated denomination range/ changes are reflected in the catalog.
Posted Jun 12, 2026 - 11:41 PDT

Identified

Effective immediately, JB Hi-Fi Gift Card Australia has a new denomination range. The UTID (U013685) is the same. The change is as follows:

New denomination range has increased from A$1,000 to A$2,000:

A$5.00 AUD - A$2,000.00 AUD
Posted May 19, 2026 - 10:24 PDT
This incident affected: Oceania (AUD).