Item Outage - RedDoorz Kartu Hadiah Indonesia Rp 1.000.000

Incident Report for rewards

Resolved

This item is no longer available.
Posted Feb 20, 2025 - 16:55 PST

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is:
U500207
Posted Apr 18, 2024 - 10:37 PDT
This incident affected: Asia (IDR).