Brand Outage - Repsol Spain

Incident Report for rewards

Resolved

This brand is now back in stock and available for ordering.
Posted Mar 17, 2026 - 07:44 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U233764, U415554, and U242710
Posted Mar 16, 2026 - 09:05 PDT
This incident affected: Europe (EUR (Spain)).