Item Outage - Lifestyle E-Gift Card ₹2000

Incident Report for rewards

Resolved

This item is still out of stock due to a brand level outage for multiple denominations. Please follow this link to the most recent status updates for the brand: https://rewardstatus.tangocard.com/incidents/cf7z1p4v2ly3
Posted May 13, 2025 - 10:32 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U344641
Posted Apr 28, 2025 - 06:38 PDT
This incident affected: Asia (INR).