Brand Outage - Biedronka Gift Card Poland

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 08:51 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U388082, U784439, and U532186
Posted Apr 02, 2025 - 10:57 PDT
This incident affected: Europe (PLN).