Brand Outage - Myer

Incident Report for rewards

Resolved

This brand is now back in stock and available for ordering.
Posted Oct 28, 2025 - 07:58 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U293834, U166632, U193593, U459744, U815270, and U322901
Posted Oct 09, 2025 - 08:55 PDT
This incident affected: Oceania (AUD).