Item Deprecation - Dárkový poukaz adidas Česká republika Kč250

Incident Report for rewards

Update

Effective immediately, Dárkový poukaz adidas Česká republika Kč250 is no longer available through Tango.

The affected UTID(s) are: U502455
Posted Feb 10, 2025 - 14:31 PST

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U502455
Posted Dec 09, 2024 - 07:26 PST
This incident affects: Europe (CZK).