Brand Outage - 1-800flowers.com

Incident Report for rewards

Resolved

This item is now back in stock and available for ordering.
Posted Mar 27, 2026 - 11:36 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U106098, U683701, and U935268
Posted Mar 26, 2026 - 09:34 PDT
This incident affected: Americas (USD).