Increased Errors - Amazon INR

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 15:01 PDT

Investigating

We are experiencing an increase in errors with Amazon India orders. The issue is currently being investigated.

The affected brands are:

Amazon.IN
Posted Apr 13, 2026 - 14:28 PDT
This incident affected: Asia (INR).