Brand Outage - Kitamura Camera Japan

Incident Report for rewards

Resolved

Please note, this brand has been deprecated and is no longer available through Tango.
Posted Oct 08, 2025 - 13:30 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U138754, U250646, U844586, U961593, U574264, and U352245
Posted Sep 26, 2025 - 10:22 PDT
This incident affected: Asia (JPY).