Increased Errors - Mastercard & Visa Cards

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 12:50 PST

Investigating

We are experiencing an increase in errors with Mastercard & Visa orders. The issue is currently being investigated.

The affected items are:
Virtual Promotional Prepaid Mastercard USD
Virtual Universal Prepaid Mastercard® CAD
Virtual Promotional Visa® Prepaid Card - US Only
Virtual Promotional Visa® Prepaid Card
Posted Nov 07, 2025 - 10:21 PST
This incident affected: Americas (CAD, USD).