Brand Outage -Amazon.AE UAE
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Nov 15, 2024 - 08:17 PST
Investigating
This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U386172, U713596, & U671157
Posted Nov 14, 2024 - 09:49 PST
This incident affected: Middle East (AED).