Item Outage - Submarino.com Virtual Gift Card R$100
Incident Report for rewards
Resolved
This outage has been resolved.
Posted Apr 19, 2021 - 12:52 PDT
Identified
Submarino.com Virtual Gift Card R$100 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U344592
Posted Apr 13, 2021 - 09:38 PDT
This incident affected: Americas (BRL).