Increased Errors - PVR Inox Cinemas India

Incident Report for rewards

Resolved

This brand is now back in stock and available for ordering.
Posted Sep 03, 2025 - 06:17 PDT

Investigating

We are experiencing an increase in errors with PVR Inox Cinemas India orders. The issue is currently being investigated.

The affected UTIDs are:
U249622
U765569
U157483
U102513
U568673
Posted Sep 02, 2025 - 16:10 PDT
This incident affected: Asia (INR).