Increased Errors - Amazon.in

Incident Report for rewards

Resolved

This issue has been resolved and these UTIDs are now back available to order.
Posted Oct 08, 2025 - 13:12 PDT

Investigating

We are experiencing an increase in errors with Amazon.in orders. The issue is currently being investigated.

The affected UTID is: U128141, U738315, U883093, U884558, and U481200
Posted Oct 08, 2025 - 11:13 PDT
This incident affected: Asia (INR).