Inactivated Item - Apple Music Code 3 Months
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jan 22, 2021 - 14:22 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 16, 2020 - 12:42 PST
Update
We are continuing to work on a fix for this issue.
Posted Nov 16, 2020 - 12:40 PST
Identified
Apple Music Code 3 Months is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U578397
Posted Nov 12, 2020 - 11:05 PST
This incident affected: Americas (USD).