Item Outage - IVI+ Kazakhstan Gift Card ₸3600

Incident Report for rewards

Resolved

This brand is no longer available.
Posted Mar 28, 2025 - 10:42 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U966370
Posted Mar 17, 2025 - 08:36 PDT
This incident affected: Asia (KZT).