Catalog Change Notice - Target eGiftCard

Incident Report for rewards

Update

Please note as of 07/22/2026, Target eGiftCard is now restored back to the original denomination range of $1.00 USD - $2,000.00 USD.
Posted Jul 22, 2026 - 08:45 PDT

Identified

Effective immediately, Target eGiftCard has a new denomination range. The change is as follows:

No longer available:

$1.00 USD - $2,000.00 USD

New denominations:

$10.00 USD - $500.00 USD
Posted Jul 21, 2026 - 14:43 PDT
This incident affects: Americas (USD).