Brand Deprecation - Flightgiftcard Luxembourg
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 13:54 PDT
Identified
Effective immediately, Flightgiftcard Luxembourg is no longer available through Tango.

The affected UTID(s) are: U164930, U374451, U225775
Posted Mar 25, 2024 - 13:16 PDT
This incident affected: Europe (EUR (Luxembourg)).