Brand Outage - Tottus Tarjeta de Regalo Chile
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Nov 17, 2024 - 22:45 PST
Investigating
This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U712703, U759296, U783341
Posted Nov 11, 2024 - 12:34 PST
This incident affected: Americas (CLP).