Item Outage - Alser.kz подарочная карта ₸10000

Incident Report for rewards

Resolved

This item is no longer available.
Posted Mar 10, 2025 - 16:47 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTID is: U643693
Posted Feb 14, 2025 - 11:13 PST
This incident affected: Asia (KZT).