Brand Outage - IKEA Portugal

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 06:41 PDT

Update

We are continuing to investigate this issue.
Posted Mar 17, 2025 - 06:41 PDT

Investigating

This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U247275, U508582, U199290, U868526, U361201, U935377, U308233, & U933396
Posted Mar 14, 2025 - 08:43 PDT
This incident affected: Europe (EUR (Portugal)).