Item Outage - Non-MX Sales - Amazon.com.mx Gift Card $2000 - 5/2/2021
Incident Report for rewards
Resolved
This outage has been resolved.
Posted May 03, 2021 - 10:01 PDT
Identified
Non-MX Sales - Amazon.com.mx Gift Card $2000 is currently unavailable. We will post an update when this reward is once again available.

The affected UTID is: U750618
Posted May 02, 2021 - 17:05 PDT
This incident affected: Americas (MXN).