Item Deprecation - Kigso Games Gift Card $5

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 08:58 PDT

Identified

Effective immediately, Kigso Games Gift Card $5 is no longer available through Tango.

The affected UTID(s) are: U412922
Posted Aug 24, 2026 - 07:50 PDT
This incident affected: Americas (USD).