Brand Deprecation - Wayfair Deutschland

Incident Report for rewards

Resolved

This incident has been resolved.
Posted Feb 13, 2025 - 10:39 PST

Identified

Effective immediately, Wayfair Deutschland is no longer available through Tango.

The affected UTID(s) are: U626300, U163283, & U810845
Posted Jan 13, 2025 - 10:28 PST
This incident affected: Europe (EUR (Germany)).