Item Outage - Amazon.se Gift Card

Incident Report for rewards

Resolved

This item is now back in stock and available for ordering.
Posted Jun 05, 2025 - 12:30 PDT

Identified

This item is currently out of stock. We will post an update when it is available.

The affected UTIDs are: U172704 and U191945
Posted Jun 02, 2025 - 06:30 PDT
This incident affected: Europe (SEK).