Brand Outage - Amazon.in
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 11:17 PST
Identified
This brand is currently unavailable. We will post an update when it is available.

The affected UTIDs are: U884558, U574083, U883093, U478645, U738315, U128141, U165089, U481200, U705529
Posted Nov 13, 2024 - 09:32 PST
This incident affected: Asia (INR).