Item Outage - Amazon Pay Gift Card India

Incident Report for rewards

Resolved

This incident has been resolved.
Posted May 05, 2025 - 13:04 PDT

Update

The following additional items are currently out of stock and unavailable: U705529, U574083, U883093, U478645, U738315, U165089, U481200
Posted Apr 30, 2025 - 06:33 PDT

Identified

These items are currently out of stock. We will post an update when they are available.

The affected UTID is:
U840890
U128141
U738315
U883093
U884558
Posted Apr 28, 2025 - 11:29 PDT
This incident affected: Asia (INR).