Increased Errors - GrabFood Gift Card S$15
Incident Report for rewards
Resolved
This outage has been resolved.
Posted Aug 10, 2021 - 10:49 PDT
Identified
GrabFood Gift Card S$15 is currently unavailable. We will post an update when the outage is resolved.

The affected UTID is: U296820
Posted Aug 05, 2021 - 02:37 PDT
This incident affected: Asia (SGD).