Item Deprecation - Cartão PlayStation Store Brazil R$30
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 12:12 PDT
Identified
Effective immediately, Cartão PlayStation Store Brazil R$30 is no longer available through Tango.

The affected UTID(s) are:
U224707
Posted May 01, 2024 - 09:30 PDT
This incident affected: Americas (BRL).