Brand Outage - Media Markt Portugal
Incident Report for rewards
Resolved
This incident has been resolved.
Posted Jun 28, 2024 - 10:21 PDT
Identified
This brand is currently out of stock. We will post an update when it is available.

The affected UTIDs are:
U531482
U182597
U617419
U216145
Posted May 14, 2024 - 10:12 PDT
This incident affected: Europe (EUR (Portugal)).